Share This:

The team behind IBrowse is working on a new version of Ibrowse (2.5). The new edition will require AmigaO4.1 FE and all components are fully AmigaOS 4 native, taking full advantage of the new features available in the latest release of AmigaOS 4, AltiVec acceleration will also be utilized in the new release. IBrowse 2.5 will no longer support  SSLv2, SSLv3 and MiamiSSL. Instead it requires AmiSSL v4 which is based on the very latest OpenSSL, it allows IBrowse to load websites that require the very latest encryption ciphers and protocols. IBrowse is a popular MUI-based web browser for Commodore Amiga computers and was the first web browsers for Commodore AmigaOS classic in 1997. Release and price is TBA.

More news: Generation Amiga magazine