AmiKit Recently announced that the upcoming AmiKit live update (10.5.1) will bring support for AmigaOS 3.1.4. You will be able to update your AmiKit (running on OS3.9, 3.5 and probably OS3.1 too) with the latest AmigaOS 3.1.4 from Hyperion Entertainment with a single click. Later they will will provide a new AmiKit installer so you will be able to install fresh AmiKit with AmigaOS 3.1.4 directly – that means without installing it with OS3.9, 3.5 or 3.1 first.

More news: Generation Amiga magazine